AnsweredAssumed Answered

Coordinator is getting stopped

Question asked by Harini-Pasuapthy on Jun 3, 2015
Latest reply on Jul 29, 2015 by Harini-Pasuapthy


Hi,

 

We have Registry, Coordinator and Simulator running in a machine, where coordinator goes down often.

The following message is found in the Coordinator log.

2015-06-02 12:48:42,089Z (13:48) [Event Sink Thread Pool Thread 1] INFO  com.itko.lisa.coordinator.CoordinatorServerImpl - Removing idle coordinator Coordinator13 2015-06-02 12:48:42,092Z (13:48) [Async colocated call thread 23] INFO  com.itko.lisa.net.ServerRequestHandler - Scheduling removal of tcp://hoatname:2011/8A5B0942092511E5B3E6005056B233B8

The following error in Registry log

2015-06-02 12:48:53,399Z (13:48) [ServerRequestResponder 85] INFO  com.itko.lisa.coordinator.TestRegistryImpl - Asked to remove coordinator server tcp://apptuvirtual10f.machine.test.group:2011/Coordinator from lab :Default 2015-06-02 12:48:54,860Z (13:48) [pool-8-thread-1] INFO  com.itko.lisa.report.services.QueryService - no step summaries available for type: C case: 82C2B61FF4C911E493E1B8CA3AB841B6 2015-06-02 12:48:54,868Z (13:48) [pool-8-thread-1] INFO  com.itko.lisa.report.services.QueryService - no step summaries available for type: C case: A0BF4BE9FA2611E4AB13B8CA3AB841B6 2015-06-02 12:48:55,367Z (13:48) [ServerRequestResponder 85] INFO  com.itko.lisa.coordinator.TestRegistryImpl - Asked to remove simulator tcp://apptuvirtual10f.machine.test.group:2014/Simulator from lab Default 2015-06-02 12:48:55,373Z (13:48) [pool-384-thread-1] ERROR System.err                     - Jun 02, 2015 1:48:55 PM com.itko.activemq.ActiveMQMessageConsumer$4 run SEVERE: ID:apptuvirtual10f.machine.test.group-42247-1433014209252-3:8:1:1 failed to delivered acknowledgements com.itko.jms.JMSException: Channel was inactive for too long: apptuvirtual10f.machine.test.group/10.240.3.168:2014 at com.itko.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:62) at com.itko.activemq.ActiveMQConnection.doAsyncSendPacket(ActiveMQConnection.java:1259) at com.itko.activemq.ActiveMQConnection.asyncSendPacket(ActiveMQConnection.java:1251) at com.itko.activemq.ActiveMQSession.asyncSendPacket(ActiveMQSession.java:1863) at com.itko.activemq.ActiveMQSession.sendAck(ActiveMQSession.java:2029) at com.itko.activemq.ActiveMQMessageConsumer$4.run(ActiveMQMessageConsumer.java:722) at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) at java.util.concurrent.FutureTask.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: com.itko.activemq.transport.InactivityIOException: Channel was inactive for too long: apptuvirtual10f.machine.test.group/10.240.3.168:2014 at com.itko.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:247) at com.itko.activemq.transport.TransportFilter.oneway(TransportFilter.java:85) at com.itko.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:104) at com.itko.activemq.transport.MutexTransport.oneway(MutexTransport.java:40) at com.itko.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60) at com.itko.activemq.ActiveMQConnection.doAsyncSendPacket(ActiveMQConnection.java:1257) ... 10 more

 

Cansomeone suggest rootcause for this issue ?

Outcomes