AnsweredAssumed Answered

XOG from 13.0 to 14.2 error "Illegal HTML character for object contentPack"

Question asked by L.Elias Champion on Jul 22, 2015
Latest reply on Sep 15, 2015 by urmas

We recently upgraded our Test system from 13.0 to 14.2. Between when we froze our test environment and completed the upgrade (almost a month, but thats another matter), we added some portlets/pages to our Train and Prod systems that are still on 13.0. I'm trying to XOG out those portlets from Prod/Train, and XOG them in to Test, but I'm getting the error below. I can run the XOG in either 13.0 system without any issues, and I've run the XML through some parsers and don't get any warnings. Anyone else having issues XOGging between versions? I tried changing the version number in the header but that made no difference. Attached is the XML I get from the 13 systems I've tried with a few different portlets but most have custom objects/attributes, I think this one has only standard fields from the base install and the PMO accelerator pack (Status Reports)

 

<?xml version="1.0" encoding="UTF-16"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <soapenv:Header/>
  <soapenv:Body>
    <XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">
      <Status elapsedTime="0.0 seconds" state="FAILURE"/>
      <Statistics failureRecords="0" insertedRecords="0" totalNumberOfRecords="0" updatedRecords="0"/>
      <ErrorInformation>
        <Severity>FATAL</Severity>
        <Description>Exception while processing client request</Description>
        <Exception type="com.niku.xog.XOGException">Input document contains Illegal HTML character for object contentPack</Exception>
      </ErrorInformation>
    </XOGOutput>
  </soapenv:Body>
</soapenv:Envelope>

Attachments

Outcomes