AnsweredAssumed Answered

Still can't get Jaspersoft to run as a Windows Service

Question asked by Rob-BBT on Aug 10, 2015
Latest reply on Aug 11, 2015 by GeorgSchmid2014

I have seen the threads about how to get Jaspersoft to run as Windows Service and have had no luck.

 

It runs fine when I run the startup.bat file and leave the server logged in, but of course as soon as I log off this shuts the window down and terminates the connection which is unacceptable.

 

I have tried installing the service which gets created and I can launch the Tomcat Manager app, but cannot start the reportservice.

 

I have tried adding -Duser.home=C:\Users\XXXXX  to the Java parameters in tomcatw.exe as I have seen articles which say that Jaspersoft is looking in the wrong place for the keystore if you don't specify the user.home but that just causing the browser to hang indefinitely when I do that.

 

This is getting extremely frustrating as we need to test this out in our Dev environment to be able to make a recommendation to move forward with our upgrade from 13.3 to 14.2,  I know you can run 14.2 without Jaspersoft but our user base is really looking to be able to use Jaspersoft instead of the clunky old BO/Crystal.

 

I have talked to support and they say it's hit or miss in terms of being able to get it to run as a service.

 

I cannot believe CA would bundle a product that has such a klugy installation/startup. 

Outcomes