Sagi_Gabay

Tech Tip - CA Identity Manager: Correct JCE Unlimited Strength files

Discussion created by Sagi_Gabay Employee on Aug 11, 2015

As documented, Identity Manager requires the JCE Unlimited Strength for integration with SiteMinder.

 

Customers many times run into a mistake where they install or deploy JCE files that aren't matching their Java Virtual Machine.

The JCE Unlimited Strength files must match both the vendor and the version of the JVM that's running Identity Manager to meet the requirement.

 

Usually JBoss is running Oracle Sun Java. In these cases you need to know the java version and download the JCE files from Oracle Sun Java site and follow their installation/deployment instructions.

 

However, with Web Sphere customers usually are more prone to errors. First, Identity Manager supports web sphere with either Oracle Sun Java or IBM Java. Most customers use IBM Java since it's more native to Web Sphere. Whatever your choice is (and make sure it is supported with your Identity Manager version per our support matrix - listed and available on our support site), you must make sure to get the JCE files of that specific JVM version from that specific vendor. Many times customers are downloading Oracle Sun Java unlimited strength JCE files despite that their web sphere is using IBM java. This can not and will not work.

 

Usually, customers are less aware of IBM Java's unrestricted JCE files. Here is a link where you can download it:

IBM Unrestricted SDK JCE policy files 2015/08/11 11:39:50

 

Yours,

Sagi Gabay,

CA Technologies.

Outcomes