AnsweredAssumed Answered

14.3 Upgrade getting stuck

Question asked by Rob-BBT on Oct 6, 2015
Latest reply on Oct 10, 2015 by Chris_Hackett

So we're trying to upgrade a QA environment from 13.3 to 14.3 and the installer seems to hang or get stuck at this point every time I run it:

 

Previous schema directory: D:\CA\Clarity\upgrade\infrastructure\previousSchema

Option: filtering on type "^pre-upgrade$"

Option: -updateHistory=false - update history will not be recorded for this sess

ion.

Loading DBDriver file: D:\CA\Clarity\upgrade\database\schema\driver.xml

Loading DBDriver file: D:\CA\Clarity\upgrade\database\schema\driver.xml

Current database version is database_20140924_1800

DBDriver for database_20140919_0726

Start installation of DBDriver ...

 

Note: Foreign Keys have been disabled

Process - pre-upgrade: CLEANUP_CMN_CONFIG.xml

Process - pre-upgrade: CRV_SEGMENT_TYPES.xml

Process - pre-upgrade: PREUPGARDE_DELDUP_ODFSUBVIEW_COSTPLANDETAIL_CLRT_74359.xm

l

Process - pre-upgrade: PREUPGRADE_CRV_STUFF.xml

Process - pre-upgrade: SEEDDATA_CMN_LANGUAGES.xml

Process - pre-upgrade: UPDATE_BPM_ERRORS.xml

Process - pre-upgrade: UPDATE_CMN_INSTALL_HISTORY.xml

Process - pre-upgrade: UPDATE_CMN_LOV_OBJECTS.xml

Process - pre-upgrade: UPDATE_OBSNAMES_SPECIAL_CHARS.xml

Process - pre-upgrade: make_page_layouts_editable.xml

 

It hangs there for a good 45 minutes at which point I cancel it and try to re-run it with install force which then fails altogether.

 

After restoring the database back to a good known version of 13.3 and restoring the Clarity filesystem from backup if I run the installer again it hangs at the exact same spot.

 

So I'm wondering if anyone else has experienced this - is this normal and is just a step that takes a really really long time which somehow I doubt.

Outcomes