AnsweredAssumed Answered

CA APM .NET Installation

Question asked by Winkle_Khurana on Oct 12, 2015
Latest reply on Oct 21, 2015 by Guenter_Grossberger

Hi All,

 

Need your support, While Installing CA APM 10.0 .Net Agent at production through interface Installation with SOA enabled few of the applications are not responding showing error please suggest the cause behind that and action corresponding to it.

 

Steps Performed

  • Installed CA APM 10.0 without SOA enabled all application are working fine whereas after enabling SOA with below steps again my applications are not responding.

Update the .NET Agent Manually to Use CA APM for SOA (Installing and Configuring CA APM for SOA)

You can manually update the .NET agent to use CA APM for SOA after installing. You move files from the <Agent_Home>/examples directory to the <Agent_Home>/ext directory and edit the default ProbeBuilder list to include CA APM for SOA files. After you update the agent profile, you configure agent properties after installation.

Follow these steps:

  1. Navigate to the <Agent_Home>\examples\SOAPerformanceManagement folder.
  2. Copy the files from the <Agent_Home>\examples\SOAPerformanceManagement\ext folder to the <Agent_Home>\ext folder.
  3. Copy the wily.WCFServicesAgent.ext.dll file from the <Agent_Home>\examples\SOAPerformanceManagement\wcf\ext folder to the <Agent_Home>\ext folder.
  4. Stop the IIS application server.
  5. Open the <Agent_Home>\IntroscopeAgent.profile file in a text editor and add the spm.pbl value to the introscope.autoprobe.directivesFile property in the IntroscopeAgent.profile file.
    For example:
    introscope.autoprobe.directivesFile=default-full.pbl,hotdeploy,spm.pbl
  6. Modify any additional agent properties in the IntroscopeAgent.profile file if you want to change the default settings.
  7. Save the file and exit the text editor.
  8. After you complete the configuration, restart the IIS server. The .NET agent is updated to use CA APM for SOA.

 

Observations:

1. metrics are reporting fine with full fledged backend data

2. Port 5001 is opened which is my connection port

3. With "netstat" command was able to see the port 8080, 8081 and 5001 is not in used by the applications

 

Please suggest waiting for the response..

Regards

Winkle Khurana

Outcomes