AnsweredAssumed Answered

webservices_rest setup confusion

Question asked by a.pietersen on Nov 12, 2015
Latest reply on Nov 16, 2015 by a.pietersen

Hi,

 

I am trying to add the webservice_rest application under the wasp. Documentation says:

Deploy the webservices_rest Package

To deploy the package, drag and drop the webservices_rest package from your local archive to a robot running the WASP probe.

The default configuration of the Tomcat server that serves as the platform for UMP does not allow encoded forward-slash characters (“/”) in URLs. To avoid problems (for example, when requesting QoS metrics that contain a forward slash in the name), add the following key to the java startup arguments of the wasp probe:

-D org.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true

Once the deployment process has completed, restart the wasp probe where you deployed the package

 

full url of this document: Set Up RESTful Webservices - CA Unified Infrastructure Management - 8.31 - CA Technologies Documentation

 

What do they mean here? / What do I miss here?

 

As said before : The use of more details and/or concrete examples should be very helpful in the documentation.

 

nb. yes I understand that some methods shown below should have the same effect, but if all methods not giving the expected results I get confused.

 

1) adding the key under the standard startup of the wasp? (there is already a -D key statement there, how should I combine these two?, syntax?)

Shoud I use a seperator like <space>  "," , " :",   " ;",    "/", " -"  ----------> how wonderful would be an full example

 

2) adding the key under the specific REST webapp?

 

3) adding the key using the raw-configurator?

 

 

4) adding the key in the plain text / xml file?

 

Does someone has a tip for me on this?

 

Thanks

Ashley Pietersen

Outcomes