AnsweredAssumed Answered

Tracer Class Mapping in required.pbd

Question asked by bwcole on Dec 9, 2015
Latest reply on Dec 10, 2015 by Carl_Young

Howdy Community,

 

We are currently upgrading from v9.6 to v10.0 and we have issues with the Java agent (websphere 7 with ibm jre 1.6) with the following error in the autoprobe log

 

[ERROR] [IntroscopeAgent.Agent] Introscope AutoProbe will not run because the provided directives files are not valid: Can't proceed because 
the specified tracer "MethodCalledErrorReporter" is invalid. Please restart with valid directives.

Reviewing the required.pbd there are two trace mappings that are commented out

# SetTracerClassMapping: MethodCalledErrorReporter com.wily.introscope.agent.trace.hc2.MethodCompletedErrorReportingTracer 
com.wily.introscope.probebuilder.validate.MetricNameValidator
# SetTracerClassMapping: HTTPErrorCodeReporter com.wily.introscope.agent.trace.hc2.HTTPErrorCodeReporter 
com.wily.introscope.probebuilder.validate.ResourceNameValidator

does anyone know why these mappings are commented out in the out of the box required.pbd for the version 10.0 java agent?

Thanks,
Billy



Outcomes