AnsweredAssumed Answered

Recording IBM WebSphere MQ -- Missing required IBM JMS jar files

Question asked by jeff.wallace on Jan 15, 2016
Latest reply on Jan 21, 2016 by Kevin.Bowman

I'm attempting to do this with ::

CA DevTest 9.0

IBM WebSphere MQ Runtine 8.0.0


 

I'm trying to figure out how to create a virtual service by recording transactions to/from IBM WebSphere MQ.  When I select the "IBM MQ Series (Deprecated)" transport protocol as defined in the official instructions, I get the following error.

 

Missing_IBM_JARS.png

 

 

I found this very similar discussion in the community and followed the advice of MarcyNunns

I went to my MQ installation {MQ_HOME/java/lib} and copied all of the JAR files and moved them into my DevTest CLASSPATH {LISA_HOME/lib}.  (Initially, I only copy/pasted the JARs defined in that screenshot, but my MQ installation doesn't have the com.ibm.mqbind.jar or the dhbcore.jar)

 

However, even after copying all of the JARs into my LISA_HOME/lib and restarting the Workstation, I still get the exact same error.

 


Here are all of the JARs that I do have in my MQ installation ::

com.ibm.mq.allclient.jar

com.ibm.mq.axis2.jar

com.ibm.mq.commonservices.jar

com.ibm.mq.defaultconfig.jar

com.ibm.mq.headers.jar

com.ibm.mq.jar

com.ibm.mq.jmqi.jar

com.ibm.mq.jms.Nojndi.jar

com.ibm.mq.pcf.jar

com.ibm.mq.postcard.jar

com.ibm.mq.soap.jar

com.ibm.mq.tools.ras.jar

com.ibm.mq.traceControl.jar

com.ibm.mqjms.jar

fscontext.jar

jms.jar

jta.jar

libmqjbnd.so

libmqjexitstub02.so

providerutil.jar

 


 

 

Anybody have any ideas on exactly what JARs I need and where I can find them?

 

Thanks,

Jeff

Outcomes