AnsweredAssumed Answered

GRLOADER Importing CIs by CSV file to CMDB

Question asked by eduardo.lagrave on Jan 28, 2016
Latest reply on May 16, 2016 by eduardo.lagrave

Hi guys

we're using SDM 14.1 and trhough GRLOADER i'm pretended to import CIs by CSV file to CMDB. In fact I'm doing something wrong.

 

 

  • The issue is when executing GRLOADER receive this message:

--------------------------------------------------------------------------------------------------------

16:00:44.232 CI and Relationship Loader for CA Service Desk Manager R12.9.000

grCSVrdr9000 Fatal Error - unable to determine object types being imported

 

Results:

               Read   Skipped Inserts   Updates    Errors Warnings

CI                0         0 0         0         0         0

Relation          0         0         0         0         0         0

 

GRLoader completed, no data processed.

16:00:45.639 GRLoader ended

--------------------------------------------------------------------------------------------------------

 

 

  • This is GRLOADER command execution:

--------------------------------------------------------------------------------------------------------

grloader -u account -p password -s http://server:8080 -i c:\temp\prueba.csv -a -n -tf reglas.rul –E

--------------------------------------------------------------------------------------------------------

 

 

  • This the "prueba.csv" CSV file content:

--------------------------------------------------------------------------------------------------------

Este es el contenido del archivo CSV:

"Type","Name","class","System>Serial Number","GeneralInven_MACAddress_T0016","Network>IP Address"

1,"CACA-02","Servidor","VMware-42 00 7e b9 eb be 2d 2f-d9 48 93 d6 c3 77 58 ba","00:50:56:80:AB:2E","192.168.0.186"

1,"xp-client01","Servidor","VMware-56 4d 05 84 13 c3 12 4d-66 99 da 66 86 e5 7c cf","00:0C:29:E5:7C:CF","192.168.0.107"

1,"xp-client02","Servidor","VMware-56 4d d5 47 5b 8a 1b 32-b2 9c 74 42 fa 50 d1 fe","00:0C:29:50:D1:FE","192.168.0.109"

--------------------------------------------------------------------------------------------------------

 

 

  • This the "rules.rul" rule file:

--------------------------------------------------------------------------------------------------------

<ruleset>

<rule><attribute>attributename</attribute>

<from>TYPE</from><to>class</to>

<from>NAME</from><to>name</to>

<from>System>Serial Number</from><to>serial_number</to>

<from>Network Adapter[1st]>MAC Address</from><to>mac_address</to>

<from>Network>IP Address</from><to>asset_num</to>

<from>GeneralInven_SerialNumb_T0015</from><to>serial_number</to>

<from>GeneralInven_MACAddress_T0016</from><to>mac_address</to>

<from>Network>GeneralInven_IPAddress_T0017</from><to>asset_num</to>

<rulename>campos</rulename>

</rule>

</ruleset>

--------------------------------------------------------------------------------------------------------

 

 

 

 

Then, what can be wrong?

Thank you in advance

Regards

Outcomes