AnsweredAssumed Answered

Inject http traffic to tim - Asynchronous way

Question asked by HaroldMartinNetready on Feb 18, 2016
Latest reply on Feb 22, 2016 by Hallett_German

The App/http server is on Azure... and there is the main issue: they don't support a SPAN port.

I tried this way:

1. on the server (Windows 2012 Server) installed wireshark and captured the http traffic (filter: tcp.port == 80) from the exposed nic

2. on the tim installed a samba server and allowed the win server to write a pcap file with the captured http traffic

3. using an app called tcpreplay (Tcpreplay  - Pcap editing and replaying utilities ) tried to inject this pcap file to the eth stablished to read the traffic on tim.


at this point some checks are done:

  • when performing a tcpdump on the nic, there is http traffic from the pcap file.
  • on the tim packet statistics there are packets processed


BUT when I stablish the autodiscovery transaction there is none.


I even tried to set a really simple html site, with few images and links to the server itself with no sucess.


I really need any help/advice/comments to get past this frontier set by Azure since several clients are migrating their apps to this platform.


Thanks in advance for any idea.


All the findings / Errors / Successes will be posted on this site and a document will all the credits and references will be published as well