AnsweredAssumed Answered

java.lang.ClassNotFoundException: com.wily.introscope.agent.webappsupport.tomcat.trace.TomcatThreadPoolTracer

Question asked by r_conatser on Feb 23, 2016
Latest reply on Feb 23, 2016 by Hallett_German

I'm upgrading from 9.5.5. to 9.7.0.1 on a SUSE 11 server running Tomcat 7 and The Introscope agent isn't sending any metrics to the Collectors. I'm seeing this error in the catalina.out logs

java.lang.ClassNotFoundException: com.wily.introscope.agent.webappsupport.tomcat.trace.TomcatThreadPoolTracer

        at java.lang.Class.forNameImpl(Native Method)

        at java.lang.Class.forName(Class.java:186)

        at com.wily.introscope.agent.extension.DynamicClassLookup.loadDynamicClassEntry(DynamicClassLookup.java:183)

        at com.wily.introscope.agent.trace.TracerFactoryLoader.createTracerFactory(TracerFactoryLoader.java:64)

        at com.wily.introscope.agent.trace.TracerAdministrator.createTracerFactories(TracerAdministrator.java:613)

        at com.wily.introscope.agent.trace.TracerAdministrator.createProbeInformation(TracerAdministrator.java:576)

        at com.wily.introscope.agent.trace.TracerAdministrator.access$0(TracerAdministrator.java:563)

        at com.wily.introscope.agent.trace.TracerAdministrator$ProbeInformationCreator.IProbeInformationCreator_createProbeInformation(TracerAdministrator.java:722)

        at com.wily.introscope.agent.trace.ProbeLookup.getProbeInformation(ProbeLookup.java:70)

        at com.wily.introscope.agent.trace.TracerAdministrator.getProbeInformation(TracerAdministrator.java:553)

        at com.wily.introscope.agent.trace.TracerAdministrator.loadTracer(TracerAdministrator.java:239)

        at com.wily.introscope.agent.enterprise.EnterpriseAgent.IAgent_loadTracer(EnterpriseAgent.java:956)

        at com.wily.introscope.agent.AgentShim.ProbeBuilderEntryPoint_loadTracer(AgentShim.java:1144)

        at org.apache.tomcat.util.net.AbstractEndpoint.isPaused(AbstractEndpoint.java)

        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:978)

        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)

        at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314)

        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1176)

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)

        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)

        at java.lang.Thread.run(Thread.java:795)

 

I have not enable JMX and tried copy the WebAppSupport.jar to ./core/ext and still having the issue.

 

Thanks for any help,

 

Robert

Outcomes