AnsweredAssumed Answered

Problem after installing "install.14.2.0.7.16.i.jar" patch on a 14.2.0.237

Question asked by Patricio.Guarda on Mar 3, 2016
Latest reply on Mar 4, 2016 by Antonio_Arenas

Hi all!

  We were having performance issues on a Jaspersoft installation so applying a patch was recommended, so we've successfully installed patch "install.14.2.0.7.16.i.jar" on a PPM 14.2.0.237.  Unfortunately after it finished, services were not able to start again.  We even tried to destroy and re-add them and that only gave us an additional problem: nsa service is not found!

  When looking into log files we were able to notice that java location was somehow harcoded set now, like not using JAVA_HOME environment variable.

 

So we are receiving 2 kinds of errors when trying to start services, when Java is installed on c:\java\jdk1.7.0_67 and JAVA_HOME is set correctly (as patched PPM apparently expects):

 

2016/03/03 14:26:53.410 | --------------------------------------------------------------------

2016/03/03 14:26:53.426 | Advice:

2016/03/03 14:26:53.441 | Access denied errors when attempting to launch the Java process are

2016/03/03 14:26:53.457 | usually caused by strict access permissions assigned to the

2016/03/03 14:26:53.473 | directory in which Java is installed.

2016/03/03 14:26:53.488 | Unless you have configured the Wrapper to run as a different user

2016/03/03 14:26:53.519 | with wrapper.ntservice.account property, the Wrapper and its JVM

2016/03/03 14:26:53.535 | will be as the SYSTEM user by default when run as a service.

2016/03/03 14:26:53.566 | --------------------------------------------------------------------

2016/03/03 14:26:53.582 |

2016/03/03 14:26:53.708 | Critical error: wait for JVM process failed

 

And when we install Java someplace else (JAVA_HOME always set correctly!!!!):

 

2016/03/03 14:20:28.191 | --------------------------------------------------------------------

2016/03/03 14:20:28.207 | Advice:

2016/03/03 14:20:28.207 | Usually when the Wrapper fails to start the JVM process, it is

2016/03/03 14:20:28.223 | because of a problem with the value of the configured Java command.

2016/03/03 14:20:28.238 | Currently:

2016/03/03 14:20:28.238 | wrapper.java.command=C:\\Java\\jdk1.7.0_67" gateway\\bin\\java.exe

2016/03/03 14:20:28.254 | Please make sure that the PATH or any other referenced environment

2016/03/03 14:20:28.269 | variables are correctly defined for the current environment.

2016/03/03 14:20:28.285 | --------------------------------------------------------------------

2016/03/03 14:20:28.301 |

2016/03/03 14:20:28.410 | Critical error: wait for JVM process failed

2016/03/03 14:23:52.298 | --> Wrapper Started as Service

2016/03/03 14:23:52.332 | Java Service Wrapper Professional Edition 64-bit 3.5.17

2016/03/03 14:23:52.347 |   Copyright (C) 1999-2012 Tanuki Software, Ltd. All Rights Reserved.

2016/03/03 14:23:52.363 |     http://wrapper.tanukisoftware.com

2016/03/03 14:23:52.363 |   Licensed to CA, Inc. for Clarity Application Server

2016/03/03 14:23:52.378 |

2016/03/03 14:23:53.767 | The value of property 'wrapper.java.command', '"C:\\Java\\jdk1.7.0_67" gateway\\bin\\java.exe"' contains unquoted spaces and will most likely result in an invalid java command line.

2016/03/03 14:23:53.876 | Launching a JVM...

2016/03/03 14:23:53.876 | Unable to execute Java command.  Access is denied. (0x5)

2016/03/03 14:23:53.876 |     "C:\\Java\\jdk1.7.0_67" gateway\\bin\\java.exe" -server -Dcom.niku.union.instanceId=app -Dcom.niku.union.serviceId=app@HOMAPPCLARITY3:9091 -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs="C:\\CA\\apache-tomcat-7.0.55/common/endorsed" -Dcatalina.base="C:\\CA\\Clarity\\tomcat-app-deploy" -Dcatalina.home="C:\\CA\\apache-tomcat-7.0.55" -Djava.io.tmpdir="C:\\CA\\Clarity\\tomcat-app-deploy/temp" -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Djava.net.preferIPv4Stack=true -Xms2048m -Xmx6144m -Duser.country=US -Duser.language=en -XX:MaxPermSize=192m -Dsun.lang.ClassLoader.allowArraySyntax=true -XX:-UseGCOverheadLimit -Djava.library.path="C:\\CA\\Clarity\\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Java\jdk1.7.0_67\\bin;c:\ca\clarity\BIN;C:\CA\Clarity\bin;C:\Java\jdk1.7.0_67\bin" -classpath "C:\\CA\\Clarity\\bin\\wrapper.jar;C:\Java\jdk1.7.0_67 gateway\lib\tools.jar;C:\\CA\\apache-tomcat-7.0.55\\bin\\bootstrap.jar;C:\\CA\\apache-tomcat-7.0.55\\bin\\tomcat-juli.jar" -Dwrapper.key="F3Nx3jXN6T0zGJYiopJuole0AW3fW-9V" -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=1480 -Dwrapper.version="3.5.17-pro" -Dwrapper.native_library="wrapper" -Dwrapper.arch="x86" -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="600" -Dwrapper.jvmid=1 -Dwrapper.lang.domain=wrapper org.tanukisoftware.wrapper.WrapperStartStopApp org.apache.catalina.startup.Bootstrap 1 start org.apache.catalina.startup.Bootstrap false 1 stop -systemLog "C:\\CA\\Clarity/logs/app-system.log"

 

This is a screenshot of service trying to start using the -verbose option (although it gives always the same message)

servicestartappverbose.png

 

Regarding the nsa not found anymore... this is a screenshot:

nsa not found.png

Do you have any ideas? Already opened a case with CA btw.

 

Thanks!

Patricio

Outcomes