AnsweredAssumed Answered

Clarity Upgrade from V12.1.3 SP7 to 14.3

Question asked by shalinee on Apr 20, 2016
Latest reply on Apr 21, 2016 by nick_darlington

Issue in setting up Clarity Stage instance...

 

We are in initial process of upgrade and making our stage environment ready with clone of existing Production Application server and new data base server.

 

1- New Virtual Application server with compatibility of 14.3 Version (Windows 2008 R2 64 bit)

 

2- New Virtual Database server with compatibility of 14.3 Version (windows 2008 R2 64 bit and SQL Server 2012 enterprise)

 

3- Our existing production server is running on Clarity V12.1.3 SP7 with SQL Server 2005 DB

 

In order to prepare the new environment of stage for upgrade process we followed the below mentioned steps:

 

1- Installed supported version of java  "jdk1.6.0_45" on new stage app server

 

1- Installed supported version of Tomcat "apache-tomcat-6.0.26" on new stage app server

 

3- Created environment variable for Niku and Java Home

 

4- Edit Path

 

5- Copy the zip folder of Clarity from existing Production server

 

6- Extracted the zip "Clarity" folder

 

7- Updated the "properties.xml" file

 

8- Remove and add/deploy all the services

 

9- started all the services

 

10- However our Database is not showing available and when we are doing ODBC connect on same server it is connecting to the database.

We know the Clarity version of 12.1.3 SP7 does not support SQL Server 2012 that is why we put 2008 backward comparability on SQL Server 2012 .

Still the log shows "Unsupported database version for vendor mssql" but we would like to know if there is any way to validate the instance with changes in jdbc driver OR

what will be the upgrade path from 12.1.3 SP7 to 14.3 with SQL Server 2012.

 

Other options ..

 

Option 1->

 

1- DBA will do in place upgrade of exiting Dev database server from 2005 to 2008 then connect existing Dev Application server 12.1.3. sp7 with 2008 DB Server

2- Upgrade Clarity from 12.1.3.SP7 to 13.x because this version still supports 2008 DB Server

3- DBA will do in place upgrade of 2008 Dev database server from 2012 then connect upgrade version of clarity 13.x with  2012 DB Server because this version supports 2012 DB Server

4- Upgrade Clarity from 13.x to 14.3

 

Option 2->

Just start the upgrade with existing error to take on 13.x version.

 

 

Any help is much appreciated!

 

Thanks,

 

Shal

Outcomes