AnsweredAssumed Answered

maxIdle property for jdbc/NikuDS

Question asked by fstrazzulla on Apr 23, 2016
Latest reply on Apr 25, 2016 by Suman Pramanik

Hello everybody,

we have found a problem in CA PPM: for some reason when we call a XOG procedure (PlanXOGWriteService) the connection vs the DB remain opened (we found

in the app log a message like this ->"connection: <connession name> was never closed").

 

Waiting for a fix from CA we would like try to solve the problem setting some parameter in the connection pool to limit e.g. the maxidle connections.

(we found there  url: Configuring jdbc-pool for high-concurrency | TomcatExpert  some interesting parameter to adjust pool beavior)

 

We tried many options to intent pass ad override this parameters:

 

1) in niku_home\webroot\WEB-INF\web.xml

  <env-entry>
<env-entry-name>maxIdle</env-entry-name>
<env-entry-value>30</env-entry-value>
<env-entry-type>java.lang.Integer</env-entry-type>
<env-entry-override>False</env-entry-override>
  </env-entry>

 

2) in  tomcat_home\conf\\server xml

<Environment name="maxIdle" value="30" type="java.lang.Integer" override="false"/>

 

But there was no way to pass the parameter to the connection

 

Do you now how we can pass this parameter to Clarity?

Any help is apreciated.

 

Francesco

Outcomes