AnsweredAssumed Answered

v14.3 XOG endpoint error in GEL script

Question asked by Owen_R on Apr 26, 2016
Latest reply on Apr 26, 2016 by Lowell

Clarity 14.3

I am updating our GEL scripts after an upgrade from 12.1.3 to 14.3 and have come across a really strange error.

As part of our upgrade we have new servers so the XOG endpoint address obviously needs to change in the scripts where XOG is used.  I typically have a XOGURL parameter defined in the script, and I have changed the value to be the new address. e.g. http://banana.axa-uk.intraxa.

My script tags on /niku/xog to the XOGURL variable when I invoke the endpoint.

 

When I run the script it fails immediately with the error below (I've blacked out the server name), on the initial call to log in and get a session ID

Capture.JPG

It is appending the XOGURL variable (without the /niku/xog part) again to the endpoint variable and trying to connect to that.

I have tried hard coding the server/niku/xog path in the script and removing the parameter entirely and it still does it.

 

Any ideas?  I'm stumped.

Outcomes