AnsweredAssumed Answered

PMI not reporting in hte investigator

Question asked by HerveDOSSANTOS62350686 on May 24, 2016
Latest reply on May 24, 2016 by HerveDOSSANTOS62350686

Hi,

 

I have a problem with PMI metrics in the APM investigator . The PMI is activated in Websphere and in the apm agent too but still not reporting in the investigator.

 

# WebSphere PMI Configuration

#

# ================

# Controls collection of WebSphere's internal

# performance monitoring infrastructure (PMI) data;

# set to true to gather data from WebSphere PMI

# in the Introscope Agent.

# You must restart the managed application before changes to this property take effect.

introscope.agent.pmi.enable=true

 

# Controls for hard-coded filters.

#

# Objref filter: filter out names ending with "@xxxxx" where "xxxxx"

# is a numeric string

# You must restart the managed application before changes to this property take effect.

introscope.agent.pmi.filter.objref=false

 

# Enable collection of different PMI data categories

# by setting introscope.agent.pmi.enable.categoryName to true

# (The data category must be turned on in WebSphere to

# be visible as Introscope data).

# You must restart the managed application before changes to this property take effect.

introscope.agent.pmi.enable.threadPoolModule=true

introscope.agent.pmi.enable.servletSessionsModule=true

introscope.agent.pmi.enable.connectionPoolModule=true

introscope.agent.pmi.enable.beanModule=true

introscope.agent.pmi.enable.transactionModule=false

introscope.agent.pmi.enable.webAppModule=false

introscope.agent.pmi.enable.jvmRuntimeModule=false

introscope.agent.pmi.enable.systemModule=false

introscope.agent.pmi.enable.cacheModule=false

introscope.agent.pmi.enable.orbPerfModule=false

introscope.agent.pmi.enable.j2cModule=true

introscope.agent.pmi.enable.webServicesModule=false

introscope.agent.pmi.enable.wlmModule=false

introscope.agent.pmi.enable.wsgwModule=false

introscope.agent.pmi.enable.alarmManagerModule=false

introscope.agent.pmi.enable.hamanagerModule=false

introscope.agent.pmi.enable.objectPoolModule=false

introscope.agent.pmi.enable.schedulerModule=false

# introscope.agent.pmi.enable.jvmpiModule=false

#introscope.agent.pmi.enable.SIB\ Service=false

 

# PMI properties for Websphere Process Server

#introscope.agent.pmi.enable.WBIStats.RootGroup=true

#introscope.agent.pmi.enable.SCAStats.RootGroup=true

 

 

 

The WAS version is was 7.0.0.33

the APM agent version is 9.5.5

 

I don't have this problem on many others intrumented JVM.

 

All help is welcome!

Outcomes