AnsweredAssumed Answered

Problem in Publishing SOAP Webservice via CA Gateway 9.0

Question asked by Mathanprasath on Jun 10, 2016
Latest reply on Jun 15, 2016 by Mathanprasath

Hi There!

I'm new to CA APIM and have recently installed CA API Gateway 9.0 using Virtual appliance running under VMWare. Facing the below problem in Policy manager and tried my level best to analyse and pinpoint the issue but couldn't make thourgh finally. Kindly point me where i'm going wrong.



As part of my first hands-on using Policy manager, I have gone to option called "Publish SOAP Webservice" and in the opened  Publish SOAP Web Service wizard, First I have tried giving the Address location of JAVA Webservice running on my local machine and also triend giving the Publicly available SOAP webservice ie;weather service but only getting the below error.


Could not fetch the WSDL at location 'http://localhost:1030/Demo/services/AdminService?wsdl ': Unable to obtain HTTP response from 'http://localhost:1030/Demo/services/AdminService?wsdl ': Connection to http://localhost:1030 refused. Caused by :Connection refused


My actions:

I have used the above mentioned wsdl in SOAP UI and able to send and get the response back but only in Policy manager it fails to locate the wsdl.