AnsweredAssumed Answered

Visiting device node in USM clears its description, UIM 8.40

Question asked by alexei.matveev on Jun 23, 2016
Latest reply on Jun 23, 2016 by Gene_Howard

Hello Everyone,

 

This is UIM 8.40, the February release, I think.

 

Why does visiting the device node in USM tree view (or is it called UMP?)  consistently resets

the description field of the computer system?  I go over ~170 devices and find only a handful

of descriptions left. A meaningful search is impossible. An SQL query against

CM_COMPUTER_SYSTEM shows NULL in the column, so this is not only a "presentation" issue.

 

Today I re-imported XML files via USM external inventory --- this restores the descriptions.

But only until I visit the node again. Similarly with re-discovery --- letting (SNMP) discovery

run sets the description (to OS details as discovered, or to the string from the XML file if that

was supplied). But visiting the nodes clears most of them again.

 

Even more confusing is the fact that there are a few nodes (about 30 of 190) where the description

seems to be persistent. No Idea what is different about them.

 

Partner Support appears to be puzzled as well judging by the lack of response for some time,

so I thought I'd ask in public.

 

In general, there seem to be quite a few of devices associated with a "computer system" --

each probe: "icmp", "snmpcollector", "cm_data_import", "discovery_agent", and even "wasp"

probe (why that?) appears to create one. Each of these devices may in principle specify a separate

'description' attribute: e.g. the imported description for cm_data_import device and some OS details

as found by discovery agent for its own device replica. What are the rules to derive or update the

discovery column of the computer systems table. I assume this is the info that is displayed in

USM here.

 

Sorry for a lengthy text, I am struggling with this for weeks already.

 

Alexei

Outcomes