AnsweredAssumed Answered

Timeout error while Deploying/Redeploying EJB vsm after few minutes

Question asked by RohanD on Jul 8, 2016
Latest reply on Jul 13, 2016 by RohanD

Description & Error Message:

1)After sometime that the VSE is running, when I try to deploy/redeploy any EJB VSM, I get the below error message.

 

java.rmi.RemoteException: Timeout (45,000 ms, actual wait 45,010 ms) on server object tcp://btln000737:2013/Falcon-VSE_Prod on method addService

at com.itko.lisa.net.Transactor.transact(Transactor.java:109)

at com.itko.lisa.net.ClientBase.transact(ClientBase.java:361)

at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:271)

at com.itko.lisa.net.VSEClient.addService(VSEClient.java:103)

at com.itko.lisa.vse.ui.actions.DeployToVSEAction$1.doCallback(DeployToVSEAction.java:155)

 

at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)

at java.lang.Thread.run(Unknown Source)

 

 

2)After restarting the VSE, the problem goes away and I am able to deploy the VSM. But after a while that VSE is running, the problem begin happening again.

3)I also tried to deploy as MAR file from the server using the VSEManager tool

4)I also tried to increase the timeout to 6 minutes by adding the following VM parameter to VSEManager.vmoptions file.

-Dlisa.net.vse.longer.timeout.ms=360000

 

Still the same problem persists.

 

Could anybody please assist in resolving the issue.

Outcomes