AnsweredAssumed Answered

OAuth Authorization Server - missing or duplicate parameters

Question asked by CBertagnolli Champion on Sep 19, 2016
Latest reply on Feb 26, 2017 by Mark_HE

Disclaimer: Have been using this all of 2.5 days...so as newb as can be .

 

The OTK 3.5 was installed and I can get to the manager, create clients + keys etc. Resource owner password creds, client credentials, and SAML bearer test client all work.

 

However, the "authorization code" flow does not function. It always errors out with the message below after a POST to the ../login. In this case I'm just trying the provided test client at /oauth/v2/client/authcode...tried creating others as well and they all fail with same error.

 

Steps:

- I go to https://mytestgateway:8443/oauth/v2/client/authcode

- I choose the "Authorization Code" option

- I click "Initiate" under Initiate new OAuth handshake

- I enter my username + password

- I am display error message invalid_request

 

------------------------------

POST https://mytestgateway:8443/auth/oauth/v2/authorize/login HTTP/1.1

HTTP/?.? 400 Bad RequestServer: Apache-Coyote/1.1x-ca-err: 3001103Cache-Control: no-store

OAuth 2.0 Authorization Server

error: invalid_request
error_description: Missing or duplicate parameters

 

Logs show this:

WARNING 609 com.l7tech.server.policy.assertion.composite.ServerHandleErrorsAssertion: 11000: Policy processing caught an exception: RaiseErrorAssertion is stopping execution.

------------------------------

 

Been trying to dig through the docs but nothing stands out for me as to where to go for troubleshooting this. Any pointers would be greatly appreciated...kind of stuck in terms of what to even look for in all this OTK stuff for this problem. 

Outcomes