AnsweredAssumed Answered

Beacons can't communicate after NSA upgrade

Question asked by chris.parker on Sep 26, 2016
Latest reply on Oct 17, 2016 by chris.parker

I'm upgrading from 13.2.0.8 -> 13.2.0.9 -> 14.3.0 -> 14.3.0.8.  In both the DEV and TEST clusters, the beacon on the NSA cannot communicate with any of the beacons on the non-NSA boxes after the NSA is upgraded.  I ran a health check before each upgrade and there were no issues.  The multicast address hasn't changed, I've tried resetting the admin password, to no avail.  IGMP snooping has not been disabled.  IP addresses have not changed - all cluster members are in the same subnet.  In the TEST upgrade I checked communication at the 14.3.0 stage, and was unsuccessful.  Tech Support has not been able to find a solution.  One test suggested was for Jgroups:

 

java org.jgroups.tests.McastSenderTest1_4 -mcast_addr <multicast_address> -port <mcast port> -use_all_interfaces

 

but this doesn't work on the upgraded machine (but does on the non-upgraded boxes).  I'm running RHEL 6.8 and JDK1.8.0_101 for 14.3.

 

For DEV and TEST I ended up replacing the $NIKU_HOME directory on the non-NSA boxes with the one from the NSA, and editing properties.xml.  This resolves the problem. 

 

The PROD cluster upgrade is scheduled for two weeks, so I need a resolution.  Is copying  $NIKU_HOME a supported approach?

 

Thanks

Outcomes