gilta03

Tech Tip: Licence Package version (3.2D) differs from Test Data Repository version (3.2C) error message

Discussion created by gilta03 Champion on Sep 27, 2016
Latest reply on Apr 20, 2018 by mkgatade

Knowledge document- http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1961673.aspx 

 

Issue: 

After upgrading and opening Datamaker, I am receiving a 'Licence Package version (3.2D) differs from Test Data Repository version (3.2C)' error message.

Steps to reproduce issue:

  1. Downloaded TDM GA release to Sandbox virtual machine (VM) and individual local machines. 
  2. Executed setup.exe installation wizard for 3.6 upgrade on the Sandbox VM machine. 
  3. Went back to local machines. 
  4. Launched Datamaker. 
  5. Received error message: "Licence Package version (3.2D) differs from Test Data Repository version (3.2C)"

Note: With this example of the issue, we have TDM installed on a VM where the repository database is installed. Other users have TDM installed on their local machines, but use the repository located on the VM to connect to Datamaker. 

Environment:  

Test Data Manager (TDM), also known as Datamaker.
This could occur with any release version. 

Cause: 

This error message occurs when the repository database is out of sync with, or not upgraded to the same version as, the repository connection you are trying to use on your local machine. From the error message you can see that the repository is actually on a different version than the installation of TDM.

The error message mentions the 'License Package' and this refers to the file 'pk_gtrep_lic.tsq' in your Datamaker directory folder. This file can be found at C:\Program Files (x86)\Grid-Tools\GTDatamaker and opened with a program like Notepad ++. If you search for 'Repository version' in this file, you will see a line with the repository version listed. You can then compare this version number to the one in the error message and see that the repository is out of sync with your new or current installation. 

The repository database being out of sync with your connection after an upgrade can be caused by either an incomplete upgrade or not performing repository maintenance after upgrading. 

Resolution:

You can resolve this issue by re-executing the TDM setup installer (in case of an incomplete upgrade) and performing repository maintenance to sync your repository with your newly installed version of TDM. 

Notes before starting:

  1. These instructions assume you have already downloaded the GA release you are planning to upgrade to on the place you have TDM currently installed.
  2. You will need to know the username and password of a user in the ADMIN group in order to perform an upgrade.
  3. Please exit out of all TDM and ARD applications, as well as stop your TDoD and Remote Publish services before starting your upgrade.
  4. Review the upgrading TDM documentation: https://docops.ca.com/ca-test-data-manager/3-6/en/installing/upgrade-product-components 

Re-executing the TDM setup installer:

  1. Open the GEN#########.zip file that you downloaded from CA Support Online. Example: GEN06134301E.zip
  2. Double click the setup_GTServer_3.x.x.xx.exe file to 'Extract all' the compressed zip files. Example: setup_GTServer_3.6.0.19.exe
  3. Browse for a destination to extract the files to and then click the 'Extract' button.
  4. Again, double click the setup_GTServer_3.x.x.xx.exe file. A 'GTServer Setup' window should show.
  5. On the 'Welcome to the Prerequisites Wizard' page, click the 'Next' button. Note: If you already attempted to upgrade once, you may be prompted with an extra window to Repair or Remove the TDM installation. Click the 'Repair' option.
  6. On the 'License Agreement' page, choose the 'I accept the terms in the License Agreement' radio button and click the 'Next' button.
  7. On the 'Prerequisites' page, leave everything checked as is and click the 'Next' button. 
  8. For each prerequisite and product component click 'Next', 'Next', 'Install', and 'Finish' on the Wizard prompts.

Launch Datamaker and finish upgrading the repository:

  1. Once everything is finished installing, launch Datamaker by double clicking the icon on your desktop, or by going to your GTDatamaker directory and double clicking on the gtdatamaker.exe.
  2. Login to Datamaker with your administrator credentials and connect to the repository.
  3. You will most likely receive this error message below. Click the 'Yes' button. Note: Your database and repository versions may be different from the example error message.
     


  4. You will then be prompted for your administrator username and password. Enter the credentials and click on the green check mark in the bottom, right-hand corner.
  5. A ‘CA Test Data Manager-Datamaker Repository Schema-Update Required’ pop up will appear. On it you will be asked ‘Do you wish to run this update now?’ Click the ‘Yes’ button.



  6. You will now see a list of all your profile connections in the profile list. Connect to one and click the green button in the bottom, left-hand corner. You should now be able to access Datamaker and its toolbar. If you receive any error messages regarding the rep.xml, please review the upgrade documentation: https://docops.ca.com/ca-test-data-manager/3-6/en/installing/upgrade-product-components 
  7. The final step is to perform repository maintenance so that everything with your repository and current installation are in sync. Follow instructions in this document on how to perform repository maintenance: http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1913171.aspx 
  8. After completing your upgrade and performing repository maintenance you should no longer see your original error message.

Additional Information:
If you experience any further licensing issues, please open a support case on https://support.ca.com/irj/portal/newhome or call 1-800-225-5224. 

Outcomes