AnsweredAssumed Answered

MQ queue - no response when used from actual client

Question asked by DevTestUser on Oct 9, 2016
Latest reply on Oct 10, 2016 by DevTestUser

Hi,

 

we have many request and response queues created in IBM MQ server for LISA mq service to consume... 

 

There is issue with one particular  queue which was working until few days back.. the issue is when Client (soap service) puts message into that request queue, we are not getting response back on the response queue.. however when I see the client logs , it says no response on 'response queue' hence it is failed.. on other side we don't see any calls in LISA for server console.. So we have checked via MQ Explorer and it shows message received on request queue and processed but not getting who consumed it.. ( I hope no one else can consume that message until proper message id to correlation id matches ) 

 

just to debug more on this issue we have tried following 

1. same LISA model deployed on different queues and it works fine

2. same soap client used with different queues and it works.

 

 

the another test also I tried is, created  mq client in LISA and tried to publish and subscribe a message from there , even that works.

we are struggling  to identify where could be the issue.. 

Outcomes