6cc6acecc2c3aed5e602717cb8f4fd76

Difficulties installing git2rally

Discussion created by 6cc6acecc2c3aed5e602717cb8f4fd76 on Oct 15, 2014
Latest reply on Sep 22, 2015 by d8bc1dfa7a6d4e33c1ec4c71d425f981
Hi everyone,

I've trying to install the git2rally connector described here (https://help.rallydev.com/git-installation-user-guide" target="_blank) I used all required versions (Ruby 1.9.2, and the indicated gem versions)
I haven't touched the code in any way.
Whenever I try to run the connector for the first time, I get:

/usr/local/rvm/gems/ruby-1.9.2-p330/gems/vcseif-1.2.4/lib/vcseif.rb:20:in `require_relative': /usr/local/rvm/gems/ruby-1.9.2-p330/gems/vcseif-1.2.4/lib/vcseif/rally_vcs_connection.rb:591: syntax error, unexpected tLPAREN_ARG, expecting keyword_do_LAMBDA or tLAMBEG (SyntaxError)
    truncated_info = -> (overage = raw_msg.length) { "...
                         ^
/usr/local/rvm/gems/ruby-1.9.2-p330/gems/vcseif-1.2.4/lib/vcseif/rally_vcs_connection.rb:591: syntax error, unexpected tLAMBEG, expecting keyword_end
...-> (overage = raw_msg.length) { "- message truncated by #{ov...
...                               ^
/usr/local/rvm/gems/ruby-1.9.2-p330/gems/vcseif-1.2.4/lib/vcseif/rally_vcs_connection.rb:591: syntax error, unexpected '}', expecting keyword_end
...o 4000 character field limit" }
...                               ^
        from /usr/local/rvm/gems/ruby-1.9.2-p330/gems/vcseif-1.2.4/lib/vcseif.rb:20:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:33:in `require'
        from <internal:lib/rubygems/custom_require>:33:in `rescue in require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from git2rally.rb:35:in `<main>'

Used the latest build for Linux (git2rally-gemconn-1.2.4-cib1032.zip) and the OS I'm using is CentOS 6.5

Any ideas?

Thanks!

Outcomes