AnsweredAssumed Answered

Rally Plugin for Jenkins post-build step doesn't save when added to job

Question asked by 0b058f6ca681cd57d00f3b4e0bc35a15 on Mar 10, 2015
Latest reply on May 1, 2015 by John_Streeter
Hi,

I'm trying to use the Rally Plugin for Jenkins to post build results to our project. I have tried getting this to work using Jenkins multiple versions (1.599, 1.600, 1.601, and 1.602) and get a consistent result:

I have set up the Rally Build Publisher information (server, username, and password) in Jenkin's configuration. I add the Rally Publisher post-build step to my Jenkins job, set the workspace and project, click 'Save' (or 'Apply'.) If I reopen the job, the post-build step was not saved and isn't being executed as a part of the build. This is not happening with other plugins that I'm using (HockeyApp, AppThwack, etc.)

I'm using version 3.0.6 of the Rally Plugin for Jenkins. I've tried the unsupported 2.4.1 version as well, but it had a different set of problems that are supposed to resolved in version 3.0.6.

Can someone help me resolve this issue? Or, if not resolve it, give me pointers on how to troubleshoot it?

Thanks,
Jason

Outcomes