AnsweredAssumed Answered

Migrating from API 1.43 to v2.0 -- security token error

Question asked by njohnson1 on Mar 24, 2014
Latest reply on Mar 24, 2014 by nmusaelian
I am using the rally web service API v2.0 to perform a POST callout from Salesforce to Rally to update/create records in Rally. I see in the documentation in v2.0 a new requirement for the security token was added. I am able to successfully peform a GET request to the following endpoint:

https://rally1.rallydev.com/slm/webservice/v2.0/security/authorize

That request returns a security token which I then attach to my POST callout, ex: (?key=d508313d-ab71-4...) .. However I am still receiving an error returned reading:

"Not authorized to perform action: Invalid key"

Are there any known issues with the security token authorization? Any suggestions or examples on how to go about troubleshooting this issue would be greatly appreciated!

Outcomes