Daniel Blanco

Unable to Reset Robot Device ID

Discussion created by Daniel Blanco Champion on Nov 4, 2016
Latest reply on Nov 4, 2016 by JAllen11

So has anyone ever come across a situation where you cannot reset the robot device ID? 

We have an issue where alerts generated by this robot is sending the MDR Element ID with a CS_ID value that does not exist w/in the UIM DB. 

So for example robot1 generates an alert and in the alert properties the cs_id or the MDR Element ID is 81633 but when we search the CM_COMPUTER_SYSTEM table, this cs_id doesn't exist. This robot already went thru the discovery server remove_robot_by_CS_ID procedure and was re-recreated with a new cs_id of 121333. Yet the robot is still sending 81633.

 

So I tried running thru _reset_robot_id_clean_niscache callback on the controller yet the Robot_ID is still the same robot ID. I tried this a few times and nothing. I even logged onto the box, stopped Nimsoft Robot Watcher service, and deleted everything in the \nimsoft\niscache directory. Restarted the service and when I did a _get_info on the robot it was the same robot_ID??? How is that possible? 

We are opening a case but if anyone ever ran into the past if you figured this out please let me know.

Thank you,

Dan

Outcomes