AnsweredAssumed Answered

Agent causing failure with CAS application

Question asked by FernandoSerraPT on Nov 11, 2016
Latest reply on Nov 11, 2016 by Hallett_German

Hello guys,

We have the following situation here:

 

When we activate agent 9.5.5.0. one of our application stops to communicate with anothers.
This application is used to authorize the users of the other applications, it’s a single-sign-on application. That application is a customization of CAS by JASIG (https://wiki.jasig.org/display/CAS/Home), the customization lies in the user of our templates and the user of specific providers to authenticate.
This application verifies if the user is authorized to access the application and the sends a ticket to the application that requested the validation.
With CA wily activated this ticket is not send, or the application don’t get the ticket which result in the user not being authorized.
The username and password are correct, the CAS application authenticate it, but the application doesn’t.
We have this problem when we are using webservices that are available in the scope of the application, that is, it is necessary to be authenticated to access the webservice.
When using the login page of the application with the same username/password the application allows the user to use it…
Both CAS and the application are deployed on GlassFish Server Open Source Edition 3.1.2.2 (build 5) java -version
java version "1.7.0_72"
Java(TM) SE Runtime Environment (build 1.7.0_72-b14)
Java HotSpot(TM) Server VM (build 24.72-b04, mixed mode)
and on the same JVM.
The applications uses CDI

 

Someone have some info about this?

 

Regards,

Fernando

Outcomes