AnsweredAssumed Answered

CA Lisa Web service Virtualization -How to access the deployed virtual web service?

Question asked by sindhuget.1 on Dec 28, 2016
Latest reply on Jan 3, 2017 by Rick.Brown

Hi ,

I am Using CA Lisa DevTest 9.1.
I have similar doubt in visualizing my Get rest web service and tried what is mentioned here "https://communities.ca.com/message/241943476?commentID=241943476#comment-241943476 ". I am able to create and deploy virtual service, but not able to( or don't know how to) access the running virtual service. Can you please help in my case?

//============================================================

Here is my Request-req.txt file content,

//============================================================
GET /WebService/rest/Sample/method/5 HTTP/1.1
Accept: application/json
Content-Type: application/json
Host: ServerIP:Port # in which my original webservice is hosted
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.7)
Accept-Encoding: gzip,deflate

//============================================================

And my Response-rsp.txt file content,

HTTP/1.1 200
{'friends': ['Michael', 'Tom', 'Daniel', 'John', 'Nick']}

//============================================================

My Original web service url is http://localhost:8080/WebService/rest/Sample/method/5 , 
When I try this url in my browser, Iam getting this result 

{'friends': ['Michael', 'Tom', 'Daniel', 'John', 'Nick']}

 

But When I access the same one as the virtual service from my browser,

http://localhost:VirtualServicePortNO/WebService/rest/Sample/method/5 , 

I am getting a blank page. On F12 I am getting response code as 200, but failed to load response data.

Please refer the attached error images.

 

Thanks in advance.

Attachments

Outcomes