AnsweredAssumed Answered

8.5 Upgrade Install Failure on ADE probe startup

Question asked by Daniel Blanco Champion on Jan 5, 2017
Latest reply on Nov 1, 2017 by anmol-k

Great start here. So in my lab ran the 8.5 installation and this is an upgrade from 8.4SP2 to 8.5.

Stopped the distsrv forwarding ability and then ran the setup. It detected everything correctly and started the upgrade. 34% in it fails with:

[ An error occurred during installation. View log button then click the CANCEL button to cancel installation. ]

It doesn't even re-try to fix itself. Awesome. It won't even try to continue after hitting OK. Have to exit the installer. 

 

Anyway the error was with the attempt to restart the automated_deployment_engine probe:

2017-01-05 11:54:22,194 DEBUG probe.DistsrvController:getPackageDistributionStatus:643 [Thread-35] - DistsrvPackageDistributionStatus{strJobId=automated_deployment_engine-1483635246444, strJobDescription=NMS installation, strPackageName=automated_deployment_engine, strPackageVersion=, strRobotAddress=/UIM_NYCLAB/UIM-NYCLAB_PriHub/as-nyclab-uim, strStatus=finished, bExpiredFlag=false, nResultCode=0, strResultString=Finished, nAttemptNumber=0, nAttempts=1, nRetryAttempts=0}
2017-01-05 11:54:22,194 INFO probe.DistsrvController:distributePackageSynchronous:570 [Thread-35] - distStatus.isFinished: true
2017-01-05 11:54:22,194 INFO impl.UIMServerConfigureController:distributePackageDistsrv:2868 [Thread-35] - distsrvPkgStatus response: DistsrvPackageDistributionStatus{strJobId=automated_deployment_engine-1483635246444, strJobDescription=NMS installation, strPackageName=automated_deployment_engine, strPackageVersion=, strRobotAddress=/UIM_NYCLAB/UIM-NYCLAB_PriHub/as-nyclab-uim, strStatus=finished, bExpiredFlag=false, nResultCode=0, strResultString=Finished, nAttemptNumber=0, nAttempts=1, nRetryAttempts=0}
2017-01-05 11:54:22,194 INFO impl.UIMServerConfigureController:distributePackageDistsrv:2881 [Thread-35] - Successfully distributed package 'automated_deployment_engine'
2017-01-05 11:54:22,194 DEBUG pds.PDSController:sendPDSWithAddr:133 [Thread-35] - Sending 'probe_activate' with sid: s5..., timeout: 180000
2017-01-05 11:54:24,819 ERROR impl.UIMServerConfigureController:run:476 [Thread-35] - NimException caught
(2) communication error, Received status (2) on response (for sendRcv) for cmd = 'probe_activate'
at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:609)
at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:562)
at com.nimsoft.nimbus.NimClientSession.send(NimClientSession.java:170)
at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:263)
at com.nimsoft.install.nimcommon.pds.PDSController.sendRequest(PDSController.java:213)
at com.nimsoft.install.nimcommon.pds.PDSController.sendPDSWithAddr(PDSController.java:136)
at com.nimsoft.install.nimcommon.pds.PDSController.sendPDSWithAddr(PDSController.java:113)
at com.nimsoft.install.nimcommon.pds.PDSController.sendWithAddr(PDSController.java:108)
at com.nimsoft.install.nimcommon.probe.ProbeController.activate(ProbeController.java:677)
at com.nimsoft.install.nimcommon.probe.ProbeController.activate(ProbeController.java:654)
at com.nimsoft.install.uimserver.action.impl.UIMServerConfigureController.activateProbeCommon(UIMServerConfigureController.java:3006)
at com.nimsoft.install.uimserver.action.impl.UIMServerConfigureController.configureAde(UIMServerConfigureController.java:1302)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.nimsoft.install.nimcommon.method.NimMethodCallback.invokeMethod(NimMethodCallback.java:532)
at com.nimsoft.install.nimcommon.method.NimMethodCallback.invokeMethod(NimMethodCallback.java:516)
at com.nimsoft.install.uimserver.action.impl.UIMServerConfigureController.doConfigure_postNMSStartupPackages(UIMServerConfigureController.java:534)
at com.nimsoft.install.uimserver.action.impl.UIMServerConfigureController.doConfigure(UIMServerConfigureController.java:490)
at com.nimsoft.install.uimserver.action.impl.UIMServerConfigureController.run(UIMServerConfigureController.java:474)
at java.lang.Thread.run(Unknown Source)

 

Anyway, anyone know what the deal is here?

I checked the probes running on the pri-hub and at this point only the controller, distsrv, hdb, hub, spooler were running. I now need to stop, restart services and retry...

 

Outcomes