AnsweredAssumed Answered

Hub Tunnel Disconnects - Error code 110

Question asked by Chris_Armstrong on Feb 23, 2017
Latest reply on Mar 3, 2017 by Chris_Armstrong

Hi,

 

Every now and again, our support team receives a flood of Nimsoft Tunnel Disconnect tickets which we thought were caused by a particular client that was flooding the tunnel connection with data, therefore, causing it to drop out / restart.  We thought this because the tunnel disconnects were happening on one particular hub.

 

Here recently, we have been getting Hub Tunnel Disconnect tickets from all over (multiple hubs).  I just happened to catch the log file in time before they rolled off (log level 3), and found the following before the Hub Tunnel restarted (sensitive data removed):

 

Feb 23 13:24:43:879 [47140332755264] hub: TSESS-P-823-0 sent error message response
Feb 23 13:24:45:469 [47141801335104] hub: nimSession - failed to connect session to x.x.x.x:48002, error code 110
Feb 23 13:24:45:469 [47141801335104] hub: TSESS-P-724-8 [] could not connect locally to /Gladiator/Hub09/nimhub09/hub (x.x.x.x/48002)
Feb 23 13:24:45:470 [47141801335104] hub: TSESS-P-724-8 sent error message response
Feb 23 13:24:45:927 [47138969073984] hub: nimSession - failed to connect session to x.x.x.x:48002, error code 110
Feb 23 13:24:45:927 [47138969073984] hub: TSESS-P-694-10 [] could not connect locally to /Gladiator/Hub09/nimhub09/hub (x.x.x.x/48002)
Feb 23 13:24:45:927 [47138969073984] hub: TSESS-P-694-10 sent error message response
Feb 23 13:24:46:635 [47138011362176] hub: EXIT HUB: hub shutdown
Feb 23 13:24:46:636 [47138011362176] hub: Waiting for tunnel to terminate ...
Feb 23 13:24:46:882 [47140101978432] hub: nimSession - failed to connect session to x.x.x.x:48002, error code 110
Feb 23 13:24:46:882 [47140101978432] hub: TSESS-P-773-3 [] could not connect locally to /Gladiator/Hub09/nimhub09/hub (x.x.x.x/48002)
Feb 23 13:24:46:882 [47140101978432] hub: TSESS-P-773-3 sent error message response
Feb 23 13:24:47:498 [47139955120448] hub: nimSession - failed to connect session to x.x.x.x:48002, error code 110
Feb 23 13:24:47:498 [47139955120448] hub: TSESS-P-762-4 sent error message response
Feb 23 13:24:49:751 [47929251947392] hub: ----------------------------------------------------------------------------------------------------
Feb 23 13:24:49:751 [47929251947392] hub: ----- Hub 7.80-jh2 [Build 7.80, Nov 9 2015] initializing -----
Feb 23 13:24:49:752 [47929251947392] hub: Tunnel has started in thread [ 47929318897984 ]
Feb 23 13:24:49:788 [47929251947392] hub: ----- HUB started -----

 

As you can see, error code 110 was very prevalent before the hub tunnel dropped out.  Any info to the meaning of error 110 would be greatly appreciated.

 

Additional info:

-We have 14 hub servers that are linux boxes (centos)

-Tunnel Encryption set to Medium

-Hub tunnel SSL Settings Mode set to Normal

-UIM ver 7.5 ---- Will be upgrading this coming March to 8.47

-Hub version 7.80

 

Thanks,

Chris A.

Outcomes