AnsweredAssumed Answered

Workstation Database Error

Question asked by Benoit_B on Mar 13, 2017
Latest reply on Mar 22, 2017 by Benoit_B

Hello Everybody,

 

I'm trying to run DevTest 10.0 with Docker on SUSE Linux Enterprise Server 12 SP1  (x86_64) and MySQL 5.7. 

My first step was to use Derby and it was ok.

Now, I'm trying to run it with MySQL and I have the following error with Workstation (on windows computer) : "Connection to the registry database cannot be established. Please make sure the database is running and the credential used to connect to database is valid. If you continue, data will not be saved to the database. Do you want to continue ? Yes/No".

 

More information : 

Clicking "No", workstation shuts down. "Yes", it seems to be running.

My SQL schema used for Registry is reachable outside Docker.

I've tried to increase log level (logging.properties), but there is no specific stacktrace in workstation.log.

I've tried to add mysql-connector-java-5.1.41-bin.jar in each lib directory workstation + hotdeploy, with no success.

 

Did I miss something ? 

 

A similar problem is described here : User does not have permission to use DevTest Workstation with this registry but without any solution.

 

Regards,

 

Benoit

Attachments

Outcomes