AnsweredAssumed Answered

Can't deploy VSM from DevTest Workstation running on a remote machine

Question asked by JianhuaDong62133533 on Apr 13, 2017
Latest reply on Apr 17, 2017 by JianhuaDong62133533

Here is what happened:

 

1. When I was trying to deploy a VSM from DevTest 9.1 Workstation running on a remote window 7 machine, I got the following error message

 

   java.rmi.RemoteException: JMS Messaging problem with ServerRequestHandler for tcp://cskpcloudwn2220:2013/VSE Could not connect to broker URL: tcp://cskpcloudwn2220:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: cskpcloudwn2220; nested exception is:
 com.itko.jms.JMSException: Could not connect to broker URL: tcp://cskpcloudwn2220:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: cskpcloudwn2220
 at com.itko.lisa.net.Transporter.init(Transporter.java:395)
 at com.itko.lisa.net.Transporter.<init>(Transporter.java:318)
 at com.itko.lisa.net.Transporter.createTransporter(Transporter.java:277)
 at com.itko.lisa.net.Transporter.getTransporter(Transporter.java:211)
 at com.itko.lisa.net.Transporter.transport(Transporter.java:160)
 at com.itko.lisa.net.Transactor.transact(Transactor.java:68)
 at com.itko.lisa.net.ClientBase.transact(ClientBase.java:361)
 at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:271)
 at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:244)
 at com.itko.lisa.net.VSEClient.getServiceNames(VSEClient.java:68)
 at com.itko.lisa.vse.ui.actions.DeployToVSEAction$1.doCallback(DeployToVSEAction.java:136)
 at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
 at java.lang.Thread.run(Unknown Source)
Caused by: com.itko.jms.JMSException: Could not connect to broker URL: tcp://cskpcloudwn2220:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: cskpcloudwn2220
 at com.itko.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
 at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:309)
 at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:228)
 at com.itko.activemq.ActiveMQConnectionFactory.createQueueConnection(ActiveMQConnectionFactory.java:191)
 at com.itko.lisa.net.ActiveMQFactory.getRemoteQueueConnection(ActiveMQFactory.java:314)
 at com.itko.lisa.net.Transporter.getOrMakeConnection(Transporter.java:407)
 at com.itko.lisa.net.Transporter.init(Transporter.java:381)
 ... 12 more
Caused by: java.net.UnknownHostException: cskpcloudwn2220
 at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
 at java.net.PlainSocketImpl.connect(Unknown Source)
 at java.net.SocksSocketImpl.connect(Unknown Source)
 at java.net.Socket.connect(Unknown Source)
 at com.itko.activemq.transport.tcp.TcpTransport.connect(TcpTransport.java:497)
 at com.itko.activemq.transport.tcp.TcpTransport.doStart(TcpTransport.java:460)
 at com.itko.activemq.util.ServiceSupport.start(ServiceSupport.java:53)
 at com.itko.activemq.transport.InactivityMonitor.start(InactivityMonitor.java:127)
 at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58)
 at com.itko.activemq.transport.WireFormatNegotiator.start(WireFormatNegotiator.java:72)
 at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58)
 at com.itko.activemq.transport.TransportFilter.start(TransportFilter.java:58)
 at com.itko.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:289)
 ... 17 more

 

2. However when I was doing the thing same bon the Server  ox where DevTEst Server is running (Windows Server 2012 R2), there is no any problem.

 

3. I can connect to DevTest Server from remote DevTest  Workstation (Registry is working)

 

What might be the root cause of this issue and what is the solution to it?

 

Thanks in advance,

 

Jianhua Dong

Outcomes