AnsweredAssumed Answered

AHD05237: An internal error with surveys occurred when users click on the Survey feedback URL

Question asked by sender on Apr 17, 2017
Latest reply on May 30, 2017 by TMACUL

Version:14.1.0.3

I developed a script plugin to create and update a Ticket. The script must use Certificates to login the SDM. so I ran a command : pdm_pki -p DEFAULT . But the message show's for me : Error found. sapolicy::update_policy_with_key() not set to force a replacement of the existing public key.
and then I change the command to : pdm_pki -p DEFAULT -f . The command run successful , and create a new certificates.
But the user report they can't access the survey url : http://xxxxxxxx/CAisd/pdmweb.exe?OP=DO_SURVEY+SID=0+SVY_ID=400001+CNT_ID=ABD8248F2828DE4FB114849BC46FBB73+CNTXT_PERSID=cr:443575
I have tested all survey url like this , can't access.It shows AHD05237:An internal error with surveys occurred.
The logs shows :
ERROR bplaccess.c 3370 AHD04043:The user name or password you entered is not correct. Please try again.
ERROR freeaccess.spl 12860 Error logging in for survey for ABD8248F2828DE4FB114849BC46FBB73

Did the survey login used Certificates ? Is it because I updated the certificate to cause the survey visit to fail? How can I update certificates that survey used?

In addition, I have tried the document ID is “TEC1238652” and “TEC505171”, but failed.

In TEC1238652”,I don't know how to confirm that the survey is set to public.

This problem has a huge impact. Please Help me resolve it.

Outcomes