AnsweredAssumed Answered

Mismatching redirect_uri in OAuth 2.0 test client

Question asked by YangChen Employee on May 2, 2017
Latest reply on May 2, 2017 by YangChen

Hi,

 

I installed two Gateway 9.2 nodes(host1, host2) as cluster and setup nginx as load balancer on host3. I can login Policy Manager to operate well connecting to host3 with port 8443 which means the load balancer works well.

Now I installed OTK 3.6 and followed the guide to update the two <YOUR_SSG> in callback URL as https://host3:8443 in Test 2.0 client.

When I tried to open https://host3:8443/oauth/v2/client in browser, it was redirected to https://host3/oauth/v2/client/authcode  and can't find the site because the port is 443 in the redirected url. If I manually add port 8443 as https://host3:8443/oauth/v2/client/authcode and tried to open, the page can be opened. Then I will get error_description: Mismatching redirect_uri. Given: 'https://host3:443/oauth/v2/client/authcode' if I click the "INITIATE" button to initiate a new OAuth handshake.

 

So the issue is that the port was set to 443 in the redirect url. Does anyone have idea how to fix it?

 

If I access the test client with Gateway node1(https://host1:8443/oauth/v2/client) directly, the port in the redirect url is 8443. I didn't add any 443 listener in nginx conf file. 

 

Thanks

Yang

Outcomes