AnsweredAssumed Answered

Xflow with Service management 17

Question asked by Remy Jobin on May 5, 2017
Latest reply on Feb 9, 2018 by Raghu.Rudraraju

Hello,

 

We have just completed the update of Service Desk 12.9, Catalog 12.9 to Service Management 17. The installation process works perfectly without any errors. ServiceDesk 17 and Catalog 17 is 100% functional. We have the same behavior as before migration.

 

My question is at the Xflow interface. We are able to connect in Xflow, use it like changing status, transfert the ticket etc .. but some function does not seem to work. (like the new features "chat" into the ticket) We often have error messages at the top right in a red bubble. (CMS0004 not autorized, CMS0016 internal error) etc...

 

Here is what we have into the log. 

 

[error] m.XmppUserChatClient - "CMS0004-Non autorisé"
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using PLAIN: not-authorized
at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:365)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1048)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:952)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:967)
at java.lang.Thread.run(Unknown Source)

 

[error] m.XmppUserChatClient - "CMS0009-Echec de labonnement au statut des utilisateurs"
org.jivesoftware.smack.SmackException$NotLoggedInException: Client is not logged in
at org.jivesoftware.smack.roster.Roster.createEntry(Roster.java:466)
at modules.XmppUserChatClient.subscribeForUsersStatus(XmppUserChatClient.java:640)
at models.messages.incoming.PresenceSubscriptionMessage.execute(PresenceSubscriptionMessage.java:50)
at services.ChatWsService.processMessage(ChatWsService.java:121)
at services.ChatWsService.startService(ChatWsService.java:76)
at actors.CollabChildActor.lambda$onReceive$0(CollabChildActor.java:134)
at java.util.function.BiConsumer.lambda$andThen$0(Unknown Source)
at java.util.function.BiConsumer.lambda$andThen$0(Unknown Source)
at java.util.concurrent.CompletableFuture.uniWhenComplete(Unknown Source)
at java.util.concurrent.CompletableFuture.uniWhenCompleteStage(Unknown Source)

 

I know that version 17 has just come out but does any of you have an idea or a track to direct me?

 

I tried to do the installation of Xflow on the main server of Service Desk, same problem.

I tried to do the installation on a secondary service desk server, same problem.

I tried installing Xflow with Apache and IIS and still have the same error messages.

 

Thanks!

Outcomes