AnsweredAssumed Answered

10.5.1 - historic data not visible after upgrade

Question asked by dave.richards on May 17, 2017
Latest reply on May 17, 2017 by Sri_Guntupalli

Description & Error Message: Hi - at the weekend (13-05-2017) we upgraded our performance test environment (one MOM, 6 collectors, 1 APM DB) to version 10.5.1 with all hotfixes applied.

 

We upgraded 3 collectors using the installer - no issues.

We then produced a tar file from one of these collectors containing the 10.5.1 software and used that to upgrade the other 3 collectors. This is what we always do when we upgrade production as we have 30 collectors so its a faster way to do it.


The 3 collectors we did this way are not showing any historic data.

 

I can see that the where we did the upgrade via the installer logs show this ....

 

20170513 093650 GMT [INFO] [Manager] Using data directory: /app/data/SmartStor
20170513 093650 GMT [INFO] [Manager] Available processors is 4
20170513 093650 GMT [INFO] [Manager] Loading metadata file: /app/data/SmartStor/metrics.metadata
20170513 093652 GMT [INFO] [Manager.MetadataStore] Upgrading metadata to new version: 1

 

Then it parses all the smartstor archive…….

 

20170513 093714 GMT [INFO] [Manager] Finished populating metadata from /app/data/SmartStor and /app/data/archive - took 22657

 

However in the collectors where we upgraded via our tar file we only see

 

20170513 140620 BST [INFO] [Manager] Using data directory: /wload/zdkc/app/data/SmartStor
20170513 140621 BST [INFO] [Manager] Available processors is 24
20170513 140621 BST [INFO] [Manager] Finished slow scan from /wload/zdkc/app/data/SmartStor/1494676815000.data - took 74
20170513 140621 BST [INFO] [Manager] Finished slow scan from /wload/zdkc/app/data/SmartStor/1494678990000.data - took 71
20170513 140621 BST [INFO] [Manager] Finished slow scan from /wload/zdkc/app/data/SmartStor/1494680415000.spool - took 71
20170513 140621 BST [INFO] [Manager.MetadataStore] Initialization of metadata took 672 ms

 

You don’t get this line in the ones we upgraded using the tar files

 

20170513 093652 GMT [INFO] [Manager.MetadataStore] Upgrading metadata to new version: 1

 


There must be a flag somewhere that gets set after the installer runs to say that the “Upgrading metadata” step has been done so it doesn’t run again.

 

How can we revert that so that we can force the metadata to be upgraded if it hasn't yet been done ?

 

Cheers

Outcomes