AnsweredAssumed Answered

Weblogic 10.3 Web-services to Be monitor from CA APM

Question asked by nayakvinay on Jun 12, 2017
Latest reply on Jun 20, 2017 by Aryne

Hi Team,

Current installation scenario :
CA APM Weblogic Agent 10.1
Weblogic Application server 10.3
CA MOM 10.1
All mentioned components are running on Sun Solaris10

as we cheked the Supported SPM-SOAp stack
WebLogic 12 Native Web Services 11g (10.3.1), 11gR1 PS1 (10.3.2), 11gR1 PS2 (10.3.3), 11gR1 PS3 (10.3.4) JAX-WS; JAX-RPC

**********

We are in process to implement CA APM agent on various application servers . Out of that we found and observed that some of the Webservices which are configured in application end but same Webservices are not able populated in CA APM agent or there is some ambiguity on the same .

We have observed that :
1.> Webservices are not getting populated under CA APM WebLogic Agent (10.1) for some of the applications
2.> Some of the Webservices are failed to capture as "Webservices|Server"(publisher) But same Webservices get captured from other application server as "Webservices|Client "(as consumer)

Now we are in a big trouble to capture missing Webservices and some of Webservices are getting populated on other application as client (consumer )
To overcome on this issue we tried below mentioned solutions ,which are provided in CA APM Guide

1.> we followed steps to Add SOA-Related Extensions Manually After Installing the Agent ( All related components are already been enabled at EM side )
a.> Copying files from the appropriate <Agent_Home>/examples directory to the <Agent_Home>/core/ext directory.
i.e copying OSBAgent.jar from SOAExtensionForOSB\ext to <Path>\wily\core\ext\

b.> Configuring the agent profile to include the appropriate ProbeBuilder directives (.pbd or .pbl) for the platform-specific agent extension.
--- we have enabled OSB-typical.pbl at agent profile for all running nodes (domains).

2.> We also tried another solution by enabling the weblogic-full.pbl and OSB-full.pbl

3.> We also tried to remove the client back-end call which are getting captured under BackEnds|WebServices_Protocol//ServerName_ protnumner Path | Default
-- we removed the "WebService at {namespace}" from Webservice.pbd under Weblogic 10.3 JAX-WS Client-side web service tracers:
Please find Mentioned details for the same
1.> Line number 979 ---
#TraceOneMethodWithParametersIfFlagged: WL_CLIENT_SYNC_JAXWS_TRACING invoke(Ljava/lang/Object;[Ljava/lang/Object;Lcom/sun/xml/ws/client/RequestContext;Lcom/sun/xml/ws/client/ResponseContextReceiver;)Ljava/lang/Object; WL_CLIENT_JAXWS_BackendTracer "WebService at {namespace}"
2.> Line number 985 -----
#TraceOneMethodWithParametersIfFlagged: WL_CLIENT_JAXWS_TRACING doProcessAsync WL_CLIENT_JAXWS_ASYNC_BackEndTracer "WebService at {namespace}"

Requested your attention to resolve this issue ,As we are in a very big trouble as we found these are applicable to 2-3 applications and very critical .

Please let us know if you required any help on this .
Please keep CC to hemant.kulkarni@cognizant.com

Thanks
Vinay Nayak
+91-8939999438

Outcomes