AnsweredAssumed Answered

Added Input Control to OOTB Report; Not Filtering Report

Question asked by knoxcorr on Jul 6, 2017
Latest reply on Jul 18, 2017 by knoxcorr

I made a copy of the "Capacity vs Demand by Role" report and added an input control for "Investment Type" to the resources. I then updated the query to add "$X{IN, i.investment_type_key, investmentTypeKey_1}" to the WHERE clause of the SQL statement (in which the dwh_inv_investment table is selected as i - see attached) and added a parameter for investmentTypeKey_1 on both subreports.

 

The report loads and includes the Input Control option for Investment Type displays and populates correctly, however, if I select any option, it does not change the results that display in the report.

 

Is there a piece I have missed?

Outcomes