AnsweredAssumed Answered

Jaspersoft Reports not loading under load balanced URL

Question asked by shiva.s43 on Jul 28, 2017
Latest reply on Jul 28, 2017 by shiva.s43

Hi,

 

We have 4 Clarity app servers load balanced into https://clarityqa.turner.com and 4 Jaspersoft server load balanced into http://clarityqareporting.turner.com. Clarity is 15.2 with latest patch and Jaspersoft is 6.2.


We have issue in accessing Jaspersoft reports under load balanced Clarity URL. The reports list page shows loading and never come back. Then I changed the entryURL in CSA to point to HTTPS URL(suggested in https://communities.ca.com/thread/241745900). Now I am able to access the reports from https://clarityqa.turner.com.

 

Now I want to know if keeping HTTPS URL in HTTP entry URL doesn’t affect the application? Or any changes I need to make in the CSA?

 

<webServer schedulerUrl="https://clarityqa.turner.com" capaUrl="" sessionTimeout="" tenantTimeout="1440" sslType="implied">
<webServerInstance id="app" entryUrl="https://clarityqa.turner.com" sslEntryUrl="https://localhost:8043" port="80" enablePort="true" sslPort="8043" enableSSLPort="false" address="" connectorPort="8009" connectorAddress="" context="/niku" documentRoot="" useHttpOnlySessionCookie="false" useSecureSessionCookie="false" restContext="/ppm"/>
<webServerInstance id="nsa" entryUrl="http://localhost:8090" sslEntryUrl="https://localhost:8093" port="8090" enablePort="true" sslPort="8093" enableSSLPort="false" address="" connectorPort="8109" connectorAddress="" context="/niku" documentRoot="" useHttpOnlySessionCookie="false" useSecureSessionCookie="false" restContext=""/>
</webServer>


Thanks,
Shiva

Attachments

Outcomes