AnsweredAssumed Answered

unable to connect to registry from workstation on changing proxy in local properties

Question asked by prat130193 on Aug 17, 2017
Latest reply on Oct 30, 2017 by prat130193

I am unable to connect to devtest workstation on changing proxy in local.properties file.

getting below error in logs

2017-08-17 18:18:26,946Z (23:48) [ProcDlgThreadCallbk@78a38bac] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from class path resource [applicationContext-security.xml]
2017-08-17 18:18:27,627Z (23:48) [ProcDlgThreadCallbk@78a38bac] INFO org.springframework.context.support.GenericXmlApplicationContext - Refreshing org.springframework.context.support.GenericXmlApplicationContext@10cc77b1: startup date [Thu Aug 17 23:48:27 IST 2017]; root of context hierarchy
2017-08-17 18:18:27,842Z (23:48) [Preflighting database] INFO com.itko.lisa.gui.TestAdmin - Database preflight completed
2017-08-17 18:18:29,155Z (23:48) [ProcDlgThreadCallbk@78a38bac] ERROR com.itko.lisa.test.LisaSecurityManager - Authentication Error
org.springframework.security.authentication.AuthenticationServiceException: Error authenticating with username 'admin'
at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:167)
at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:730)
at com.itko.lisa.test.LisaSecurityManager.authenticateUser(LisaSecurityManager.java:686)
at com.itko.lisa.test.LisaSecurityManager.authenticateUserFromGUI(LisaSecurityManager.java:928)
at com.itko.lisa.gui.TestAdmin$1.doCallback(TestAdmin.java:232)
at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
at java.lang.Thread.run(Unknown Source)
Caused by: retrofit.RetrofitError: 404 Not Found
at retrofit.RetrofitError.httpError(RetrofitError.java:40)
at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388)
at retrofit.RestAdapter$RestHandler.invoke(RestAdapter.java:240)
at com.sun.proxy.$Proxy2.authenticateAndAuthorize(Unknown Source)
at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:162)
... 6 more
2017-08-17 18:18:29,251Z (23:48) [AWT-EventQueue-0] ERROR com.itko.util.swing.UserMessage - Error connecting to the DevTest Registry. Error message: Error authenticating with username 'admin'
org.springframework.security.authentication.AuthenticationServiceException: Error authenticating with username 'admin'
at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:167)
at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:730)
at com.itko.lisa.test.LisaSecurityManager.authenticateUser(LisaSecurityManager.java:686)
at com.itko.lisa.test.LisaSecurityManager.authenticateUserFromGUI(LisaSecurityManager.java:928)
at com.itko.lisa.gui.TestAdmin$1.doCallback(TestAdmin.java:232)
at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
at java.lang.Thread.run(Unknown Source)
Caused by: retrofit.RetrofitError: 404 Not Found
at retrofit.RetrofitError.httpError(RetrofitError.java:40)
at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388)
at retrofit.RestAdapter$RestHandler.invoke(RestAdapter.java:240)
at com.sun.proxy.$Proxy2.authenticateAndAuthorize(Unknown Source)
at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:162)
... 6 more

 

 

The properties which i changed

 

## ==============================================
lisa.http.webProxy.host=abc.xyz.com
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]*
lisa.http.webProxy.nonProxyHosts=localhost
lisa.http.webProxy.port=80XX

## ==============================================
## HTTPS Proxy Server
## ==============================================
lisa.http.webProxy.ssl.host=abc.xyz.com
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]*
lisa.http.webProxy.ssl.nonProxyHosts=localhost
lisa.http.webProxy.ssl.port=80XX

 

on commenting above properties its working fine.

Outcomes