AnsweredAssumed Answered

Auto close not working when End User's tenant is different

Question asked by diogo.nobrega on Sep 13, 2017
Latest reply on Dec 4, 2017 by diogo.nobrega

Hi everyone,

 

I'm having a issue regarding auto close setting when the tenant of end user is different from the tenant of the ticket and the auto close rule. The problem is, the auto close is not being 'fired' on solved status. The activity log is not even being generated.

 

To me more clear, let me explain all the situation. In our environment, we have the tenant 'X' (which is the service provider). The auto close was set for tenant 'Y' (being Y a child of X). The ticket was opened with tenant Y, using a category with tenant Y. The only thing is that the end user (and the requester) is from tenant X. In this situation, the auto close timer for tenant Y is not being triggered. I'm aware that auto close uses workshift from end user or requester, but none of them has a workshift. Shouldn't be used the 'regular' workshift?

 

We've already tested when both the end user/requester and the ticket have the same tenant, and the rule was successfully attached to the ticket.

 

Is this working as designed or there's some kind of error/incompatibility? Note that there are no errors regarding this in stdlog. And we don't wish to use a default auto close setting or an auto close setting for tenant X because we will have another child tenants which will be using different times for closing tickets.

 

Note: Service Desk Manager is 17.0 (it's a fresh install).

 

Regards,

 

Diogo

Outcomes