AnsweredAssumed Answered

How to solve SSL exception during Rest secure service test

Question asked by Shivam.garg on Sep 21, 2017
Latest reply on Sep 21, 2017 by Joel NeSmith

Hello All,

 

I am again facing issue during testing REST secure api. I enabled SSL/HTTP trace and able to see below info. I have provided cert details in local.properties file + have changed in LisaWorkstation.vmoption file with this -Dhttps.protocols=TLSv1, SSLv2 + I have tried changing in java.security file as well.

 

But still it is not passing and throwing below exception.

 

[ 1] [SSL Handshake Summary]
[ 1] [SSL Handshake Summary] RECV TLSv1 ALERT: fatal, handshake_failure
[ 1] [SSL Handshake Summary] javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

[ 1] [SSL Handshake Summary] See Alert or Exception for details

 

 

I checked with message broker team and they are saying this protocol is configured at their side. I have tried every thing in Lisa what I am aware  but not working. So please let me know any thing else I can do.

 

mqsireportproperties BDSMBRB1 -e ENQ-IIB-RestGateway -o HTTPSConnector -r
sslProtocol='SSL_TLSv2'
mqsireportproperties BDSMBRB2 -e ENQ-IIB-RestGateway -o HTTPSConnector -r
sslProtocol='SSL_TLSv2'
mqsireportproperties BDSMBRB1 -e FPS-IIB-RestGateway -o HTTPSConnector -r
sslProtocol='SSL_TLSv2'
mqsireportproperties BDSMBRB2 -e FPS-IIB-RestGateway -o HTTPSConnector -r
sslProtocol='SSL_TLSv2'

Outcomes