AnsweredAssumed Answered

Increase VSE reply timeout

Question asked by pannedl1 on Oct 19, 2017
Latest reply on Oct 20, 2017 by fulri02

Hello everyone,

 

We are using JAVA virtual services, we recorded all the JAVA calls and are in one virtual service. Sometimes for few JAVA calls, we are facing below error. 

 

[DevTest AGENT:A][ERROR][6836][35][BETAMNGR:1:99147][10/18 12:00:10 (445)] Failed to get a VSE reply within 5000ms for [8d866bc2-b436-11e7-8cc5-f8cab83f4023] com.tmobile.ensemble.XXXXX.execute. Please check VSE logs to understand why.

 

We could not find any information in the VSE logs, all we could see is the above message in the VSE logs.

 

Added the below property in Rules.xml, but still the same issue. Please help me in resolving this issue.

 

<property
comment="The maximum amount of time allowed for a VSE reply at playback"
key="lisa.agent.virtualize.reply.timeout" value="80000"/>

 

startWebLogic.cmd Java Options - using to connecting to the agent and server.

-javaagent:"C:\CA LISA\DevTest\agent\LisaAgent2.jar"=url=ssl://XXXXX.unix.gsm1900.org:2009,name=******

 

Rules.xml path - C:\CA LISA\DevTest

Outcomes