Tech Tip: Datamaker- The repository table gtrep_system is not populated so this repository cannot be used

Discussion created by gilta03 Champion on Nov 1, 2017
Latest reply on Mar 5, 2018 by AdamTopper

This document can also be viewed at

To view more documents like this, visit our knowledge base: CA Test Data Manager 


After upgrading Datamaker and connecting to the repository, I am receiving the following error message:
The repository table gtrep_system is not populated so this repository cannot be used

CA Test Data Manager (TDM)- Datamaker

If the default database you are using is not pointing to gtrep when creating an ODBC connection profile, then you will receive this error message and be unable to connect to the repository. 


To resolve this, you will need to point your 'Default Database' to 'gtrep' and you can follow the steps below to do this.  

1. Open/edit the gtrep repository connection profile in Datamaker.


edit profile.png


2. Under 'Default Schema', add 'dbo' in the text box. 

3. Click on the box icon next to the 'ODBC Source' option. 


default schema dbo.png


4. Click on the gtrep repository. 

5. Choose the 'System DSN' tab. 

6. Click the 'Configure' button. 


system dsn configure.png


7. Make sure your system details are accurate. Click Next.

8. Add your gtrep password. Click Next. 

configure system dsn step 1.png


configure system dsn step 2.png


configure system dsn step 3.png


9. Check the box for 'Change the default database'. 

10. In the drop down window, find 'gtrep'. Click Next and Finish. 


change default database to gtrep.png


11. Test the data source connection. If test was successful, click OK. 


test data source system dsn.png


test completed successfully.png


12. Re-launch Datamaker. 

13. Retest connecting to the gtrep repository. The connection should be successful.


connection details valid last.png

Additional Information:

If you experience any further issues, please open a support case by going to