AnsweredAssumed Answered

Strange behavior of XOG interface (reference is not allowed in prolog, login failed, XOG invoke failed...)

Question asked by matej256 on Nov 30, 2017
Latest reply on Dec 7, 2017 by Shoichi_Sugawara

Hi All, 

 

we are currently facing very strange issue for us we have never met before. We are using XOG (through Clarity GUI and also by command line) for many years. Firstly this week our Clarity GUI interface started to "ignore" XML characters, or better say encoding and produced error: Reference is not allowed in prolog.


 

 

I tried to change encoding to: UTF-8, UTF-8 without BOM, ANSI – without success.

Exactly this XOG (and all others I tried) works last week. 

 

After this situation I tried to use command line where another strange issue appeared. When used properties (attached) file (1. attempt) - I'm not able to connect. However through plain command line login I can (2. attempt) ... 

 

 

Error produced by not successful 1. attempt (out.xml file) says that login to requested URL failed:

 

<?xml version="1.0" encoding="UTF-8"?>
<XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">
<Object type="unknown"/><Statistics updatedRecords="0" insertedRecords="0" failureRecords="0" totalNumberOfRecords="0"/>
<ErrorInformation>
<Severity>FATAL</Severity>
<Description>XOG Invoke Failed</Description>
<Exception type="com.niku.xog.XOGException">

Login Failed: URL: http://dedussv-sjsdev2.de.henkelgroup.net:29082/niku/xog user: xoguser</Exception>
</ErrorInformation>
</XOGOutput>

 

However when I click on that URL, it is accessible and valid, as it should be...:

 

 

Do you know what this can cause? 

 

Thanks!
Matej

Attachments

Outcomes