AnsweredAssumed Answered

MySQL Connection Problem

Question asked by AndreasKrüger82324583 on Dec 3, 2017
Latest reply on Jun 28, 2018 by dassu10

Hi there, 

currently I'm facing problems to connect my Software API Gateway 9.2 to my locally installed MySQL Server 5.5 on CentOS. 

I installed successfully the Gateway and configured successfully the embedded database. After that I would like to change to a MySQL database. 

I installed the database locally. Secured the mysql database with the command mysql_secure_installation. I created a database with a name ssg. ( I tried also to not create the database ssg, but this causes to an error as well. ) After that I tried to configure the Gateway via the setup.sh script, choosed Option 2. 

But if I wanted to save my configure I received an error "Unable to connect to database".

As the user for connecting, I used the administrative user root. (The MySQL started successfully.) 

In the config.log I found the following error: 

[2017/12/03 at 18:12:10] - [INFO]: Processing configuration.
[2017/12/03 at 18:12:10] - [INFO]: Processing 0 databases.
[2017/12/03 at 18:12:36] - [INFO]: Configuring node in directory '/opt/SecureSpan/Gateway/node/default/etc/conf'.
[2017/12/03 at 18:12:36] - [WARNING]: Error while checking the version of the ssg in the database: Table 'ssg.ssg_version' doesn't exist

 

I have no idea what's going wrong? Any idea would by appreciate. 

 

Greetings 

Andy

Outcomes