gilta03

Tech Tip: FDM: Delimited File Masking Issue

Discussion created by gilta03 Champion on Jan 23, 2018

When masking a CSV file with Fast Data Masker (FDM), the scramble file is going out of format and making changes to the header as well as data fields. The header fields are double quoted in the original file, but FDM has removed those from the scramble file. The empty fields were not double quoted in the original file, but scramble has them double quoted. Also, some numeric fields towards the end of record have lost the double quotes in the scramble file. I am not sure how I get null fields to come up empty without the quotes as in the original file. 

 

I understand that in the context of opening the files in Excel both these do not make a difference, but if an application is processing the file (.dat) directly, then I believe both will mean different things. An empty double quote in a field would mean an empty string and no quotes in a field refers to a null. Is there some option or way to have FDM keep the null as is without retaining double quotes as is in the same file? 

 

Imagine a situation where that field was a numeric field. I have set NUMQUOTED=N, but the field does not contain any data for all columns then will the empty quotes turn up and in that case. We are not specifying the type of data of the column in the definition, so how does FDM know whether a date field with value 01182018 is a date field or a numeric one? 

 

To see the answer to this question, please go here- https://support.ca.com/us/knowledge-base-articles.TEC1142496.html 

 

Outcomes