AnsweredAssumed Answered

Advanced Filter not saved in the view

Question asked by snagy Employee on Apr 5, 2018
Latest reply on Apr 12, 2018 by michael.nowling

I'm using rally1.rallydev.com and I'm having issue with "Advanced Filters". I add the "Field"->"Product", "Operator"->"=" and "Value"->One Item from the list(any except "No Entry").

 

Good Filter

 

The filter is applies without any issues.

 

I save the view, change to another view, them come back to the previous view by selecting it. The value for the initial filter is blanked out and I can read "Filter by Product" on the field and I don't get the expected output.

 

 

Looking at the http request sent to the server when the view is updated I can see that the browser is sending:

 

{
   ...
   "advancedFilters": [
   {
      "name": "b378965d-14e1-4ede-8786-cd67127a15e6",
      "operator": "contains",
      "rawValue": "SDM"
   }
   ],
   ...
}

 

But if I set the value to "-- No Entry --" I see the following request being sent:

 

{
   ...
   "advancedFilters": [
   {
      "name": "b378965d-14e1-4ede-8786-cd67127a15e6",
      "operator": "contains",
      "rawValue": "/none/-1"
   }
   ],
   ...
}

 

If I add extra filters I don't see any of them being sent as a string, but they are all sent in the format /***/aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa . Not sure if this is the issue but it seems that way to me.

 

Is there an issue with the instance that I'm using or a global issue?

 

Thank you,

Sebastian

Outcomes